using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([1-9]?\d(\.\d{1,2})?|100(\.0{1,2})?)$";
string input = @"1000
101
100.01
100.00
100.0
100
12.30
12.34
12.3
12
012
1.20
1.2
1
01.2
0.10
0.1
.1
01
00
0";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}