import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([1-9]?\\d(\\.\\d{1,2})?|100(\\.0{1,2})?)$";
final String string = "1000\n"
+ "101\n"
+ "100.01\n"
+ "100.00\n"
+ "100.0\n"
+ "100\n"
+ "12.30\n"
+ "12.34\n"
+ "12.3\n"
+ "12\n"
+ "012\n"
+ "1.20\n"
+ "1.2\n"
+ "1\n"
+ "01.2\n"
+ "0.10\n"
+ "0.1\n"
+ ".1\n"
+ "01\n"
+ "00\n"
+ "0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}