// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([1-9]?\d(\.\d{1,2})?|100(\.0{1,2})?)$").unwrap();
let string = "1000
101
100.01
100.00
100.0
100
12.30
12.34
12.3
12
012
1.20
1.2
1
01.2
0.10
0.1
.1
01
00
0";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}