const regex = /^([1-9]?\d(\.\d{1,2})?|100(\.0{1,2})?)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([1-9]?\\d(\\.\\d{1,2})?|100(\\.0{1,2})?)$', 'gm')
const str = `1000
101
100.01
100.00
100.0
100
12.30
12.34
12.3
12
012
1.20
1.2
1
01.2
0.10
0.1
.1
01
00
0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}