#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^\S\n]*class Ttt {[^]*?\n\s*}\s*\n\s*use\(.*\);$"
Local $sString = " class Eee {" & @CRLF & _
" test(){" & @CRLF & _
" console.log("123");" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" use(123, Eee);" & @CRLF & _
"" & @CRLF & _
" class Ttt {" & @CRLF & _
" test(){" & @CRLF & _
" console.log("123");" & @CRLF & _
" }" & @CRLF & _
" } " & @CRLF & _
" use(456, Ttt);" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" class Ooo {" & @CRLF & _
" test(){" & @CRLF & _
" console.log("123");" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" use(111, Ooo);"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")