// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^\S\n]*class Ttt {[^]*?\n\s*}\s*\n\s*use\(.*\);$").unwrap();
let string = " class Eee {
test(){
console.log(\"123\");
}
}
use(123, Eee);
class Ttt {
test(){
console.log(\"123\");
}
}
use(456, Ttt);
class Ooo {
test(){
console.log(\"123\");
}
}
use(111, Ooo);";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}