package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^\S\n]*class Ttt {[^]*?\n\s*}\s*\n\s*use\(.*\);$`)
var str = ` class Eee {
test(){
console.log("123");
}
}
use(123, Eee);
class Ttt {
test(){
console.log("123");
}
}
use(456, Ttt);
class Ooo {
test(){
console.log("123");
}
}
use(111, Ooo);`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}