using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^\S\n]*class Ttt {[^]*?\n\s*}\s*\n\s*use\(.*\);$";
string input = @" class Eee {
test(){
console.log(""123"");
}
}
use(123, Eee);
class Ttt {
test(){
console.log(""123"");
}
}
use(456, Ttt);
class Ooo {
test(){
console.log(""123"");
}
}
use(111, Ooo);";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}