import re
regex = re.compile(r"^[^\S\n]*class Ttt {[^]*?\n\s*}\s*\n\s*use\(.*\);$", flags=re.MULTILINE)
test_str = (" class Eee {\n"
" test(){\n"
" console.log(\"123\");\n"
" }\n"
" }\n"
" use(123, Eee);\n\n"
" class Ttt {\n"
" test(){\n"
" console.log(\"123\");\n"
" }\n"
" } \n"
" use(456, Ttt);\n\n\n"
" class Ooo {\n"
" test(){\n"
" console.log(\"123\");\n"
" }\n"
" }\n"
" use(111, Ooo);")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")