import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^\\S\\n]*class Ttt \\{[^]*?\\n\\s*\\}\\s*\\n\\s*use\\(.*\\);$";
final String string = " class Eee {\n"
+ " test(){\n"
+ " console.log(\"123\");\n"
+ " }\n"
+ " }\n"
+ " use(123, Eee);\n\n"
+ " class Ttt {\n"
+ " test(){\n"
+ " console.log(\"123\");\n"
+ " }\n"
+ " } \n"
+ " use(456, Ttt);\n\n\n"
+ " class Ooo {\n"
+ " test(){\n"
+ " console.log(\"123\");\n"
+ " }\n"
+ " }\n"
+ " use(111, Ooo);";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}