package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<img.+?class=["'].*?hero-class.*?["'].*?src=["'](.+?)["'].*?>`)
var str = `// it should match but it didn't
<img src="image.jpg" class="hero-class">
// it shouldn't match class 'nohero-class-dont-match'
<img class="nohero-class-dont-match" src="image.jpg">
// it shouldn't match custom tag 'imgs-tag'
<imgs-tag class="hero-class" src="image.jpg">
// it shouldn't match two tags and text between them
<img src="foo.jpg" class="hero-class"> any text <img src="image.jpg">
// it should match whole src attribute, not just part
<img class="hero-class" src="mcdonald's.jpg">
// it shouldn't match custom attribute 'data-src'
<img class="hero-class" data-src="custom info" src="image.jpg">
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}