const regex = /<img.+?class=["'].*?hero-class.*?["'].*?src=["'](.+?)["'].*?>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<img.+?class=["\'].*?hero-class.*?["\'].*?src=["\'](.+?)["\'].*?>', 'gm')
const str = `// it should match but it didn't
<img src="image.jpg" class="hero-class">
// it shouldn't match class 'nohero-class-dont-match'
<img class="nohero-class-dont-match" src="image.jpg">
// it shouldn't match custom tag 'imgs-tag'
<imgs-tag class="hero-class" src="image.jpg">
// it shouldn't match two tags and text between them
<img src="foo.jpg" class="hero-class"> any text <img src="image.jpg">
// it should match whole src attribute, not just part
<img class="hero-class" src="mcdonald's.jpg">
// it shouldn't match custom attribute 'data-src'
<img class="hero-class" data-src="custom info" src="image.jpg">
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}