use strict;
my $str = '// it should match but it didn\'t
<img src="image.jpg" class="hero-class">
// it shouldn\'t match class \'nohero-class-dont-match\'
<img class="nohero-class-dont-match" src="image.jpg">
// it shouldn\'t match custom tag \'imgs-tag\'
<imgs-tag class="hero-class" src="image.jpg">
// it shouldn\'t match two tags and text between them
<img src="foo.jpg" class="hero-class"> any text <img src="image.jpg">
// it should match whole src attribute, not just part
<img class="hero-class" src="mcdonald\'s.jpg">
// it shouldn\'t match custom attribute \'data-src\'
<img class="hero-class" data-src="custom info" src="image.jpg">
';
my $regex = qr/<img.+?class=["'].*?hero-class.*?["'].*?src=["'](.+?)["'].*?>/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}