using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""([^\\""\r\n]*(?:\\.[^\\""\r\n]*)*)""";
string substitution = @"$1";
string input = @"3.5"" hdd
""hello""
""cool
""bounce""
single sentence with out quotes.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}