const regex = /"([^\\"\r\n]*(?:\\.[^\\"\r\n]*)*)"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"([^\\\\"\\r\\n]*(?:\\\\.[^\\\\"\\r\\n]*)*)"', 'g')
const str = `3.5" hdd
"hello"
"cool
"bounce"
single sentence with out quotes.`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);