re = /"([^\\"\r\n]*(?:\\.[^\\"\r\n]*)*)"/
str = '3.5" hdd
"hello"
"cool
"bounce"
single sentence with out quotes.'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result