$re = '/"([^\\\\"\r\n]*(?:\\\\.[^\\\\"\r\n]*)*)"/';
$str = '3.5" hdd
"hello"
"cool
"bounce"
single sentence with out quotes.';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;