// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#""([^\\"\r\n]*(?:\\.[^\\"\r\n]*)*)""#).unwrap();
let string = "3.5\" hdd
\"hello\"
\"cool
\"bounce\"
single sentence with out quotes.";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}