#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ";([^;]*?)WORD"
Local $sString = "1. (XYZTRR: KTTT 4.0.1; TVS A3003 WORD/LLLLL ; pj ;) " & @CRLF & _
"" & @CRLF & _
"2. (XcdcdRR: dTff 5.4.1; TVS A3003 WORD/UJHKKKHH fpp) " & @CRLF & _
"" & @CRLF & _
"3. (LLLhf22; 776332 8.7.1; TVS A3003 WORD/UHHGFVV phhp) "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")