package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`;([^;]*?)WORD`)
var str = `1. (XYZTRR: KTTT 4.0.1; TVS A3003 WORD/LLLLL ; pj ;)
2. (XcdcdRR: dTff 5.4.1; TVS A3003 WORD/UJHKKKHH fpp)
3. (LLLhf22; 776332 8.7.1; TVS A3003 WORD/UHHGFVV phhp) `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}