import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ";([^;]*?)WORD";
final String string = "1. (XYZTRR: KTTT 4.0.1; TVS A3003 WORD/LLLLL ; pj ;) \n\n"
+ "2. (XcdcdRR: dTff 5.4.1; TVS A3003 WORD/UJHKKKHH fpp) \n\n"
+ "3. (LLLhf22; 776332 8.7.1; TVS A3003 WORD/UHHGFVV phhp) ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}