re = /;([^;]*?)WORD/
str = '1. (XYZTRR: KTTT 4.0.1; TVS A3003 WORD/LLLLL ; pj ;)
2. (XcdcdRR: dTff 5.4.1; TVS A3003 WORD/UJHKKKHH fpp)
3. (LLLhf22; 776332 8.7.1; TVS A3003 WORD/UHHGFVV phhp) '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end