// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r";([^;]*?)WORD").unwrap();
let string = "1. (XYZTRR: KTTT 4.0.1; TVS A3003 WORD/LLLLL ; pj ;)
2. (XcdcdRR: dTff 5.4.1; TVS A3003 WORD/UJHKKKHH fpp)
3. (LLLhf22; 776332 8.7.1; TVS A3003 WORD/UHHGFVV phhp) ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}