using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @";([^;]*?)WORD";
string input = @"1. (XYZTRR: KTTT 4.0.1; TVS A3003 WORD/LLLLL ; pj ;)
2. (XcdcdRR: dTff 5.4.1; TVS A3003 WORD/UJHKKKHH fpp)
3. (LLLhf22; 776332 8.7.1; TVS A3003 WORD/UHHGFVV phhp) ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}