use strict;
my $str = '//div[1]/li/a[@href=\'https://www.facebook.com/\']';
my $regex = qr`\[[^]]+\]|(/)`mp;
my $subst = '>$1';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";