re = /\[[^]]+\]|(\/)/m
str = '//div[1]/li/a[@href=\'https://www.facebook.com/\']'
subst = '>$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result