#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^.+-REFERENCE-+([A-Za-z0-9.?\/-]*)(.*).html$"
Local $sString = "http://www.comptoirdelencens.fr/FR/produit_detail-famille-cristaux_huiles-gamme-cristaux_huiles_essentielles-REFERENCE-CR22.html"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")