const regex = new RegExp('^.+-REFERENCE-+([A-Za-z0-9.?\\/-]*)(.*).html$', '')
const str = `http://www.comptoirdelencens.fr/FR/produit_detail-famille-cristaux_huiles-gamme-cristaux_huiles_essentielles-REFERENCE-CR22.html`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}