package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^.+-REFERENCE-+([A-Za-z0-9.?\/-]*)(.*).html$`)
var str = `http://www.comptoirdelencens.fr/FR/produit_detail-famille-cristaux_huiles-gamme-cristaux_huiles_essentielles-REFERENCE-CR22.html`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}