using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.+-REFERENCE-+([A-Za-z0-9.?\/-]*)(.*).html$";
string input = @"http://www.comptoirdelencens.fr/FR/produit_detail-famille-cristaux_huiles-gamme-cristaux_huiles_essentielles-REFERENCE-CR22.html";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}