re = /^.+-REFERENCE-+([A-Za-z0-9.?\/-]*)(.*).html$/
str = 'http://www.comptoirdelencens.fr/FR/produit_detail-famille-cristaux_huiles-gamme-cristaux_huiles_essentielles-REFERENCE-CR22.html'
# Print the match result
str.match(re) do |match|
puts match.to_s
end