#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^Dear\s*user(\s*\d)?(?(1)(.{1,5})(?=(\s{1,}))(?<!(\s{2}))(.{1,5}) thanks|\s*thanks)$"
Local $sString = "Dear user 1 2222 thanks" & @CRLF & _
"Dear user12345 64789 thanks" & @CRLF & _
"Dear user12345 6479 thanks" & @CRLF & _
"Dear user12345 6489 thanks" & @CRLF & _
"Dear user 12345 64789 thanks" & @CRLF & _
"Dear user 123 5 6789 thanks" & @CRLF & _
"Dear user 123 5 68 4 thanks" & @CRLF & _
"Dear user 1 thanks" & @CRLF & _
"Dear user thanks" & @CRLF & _
"Dear user 1 2 thanks" & @CRLF & _
"Dear user 43265 thanks" & @CRLF & _
"Dear user 43265 thanks" & @CRLF & _
"Dear user thanks" & @CRLF & _
"Dear user thanks"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")