$re = '/^Dear\s*user(\s*\d)?(?(1)(.{1,5})(?=(\s{1,}))(?<!(\s{2}))(.{1,5}) thanks|\s*thanks)$/m';
$str = 'Dear user 1 2222 thanks
Dear user12345 64789 thanks
Dear user12345 6479 thanks
Dear user12345 6489 thanks
Dear user 12345 64789 thanks
Dear user 123 5 6789 thanks
Dear user 123 5 68 4 thanks
Dear user 1 thanks
Dear user thanks
Dear user 1 2 thanks
Dear user 43265 thanks
Dear user 43265 thanks
Dear user thanks
Dear user thanks';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);