import re
regex = re.compile(r"^Dear\s*user(\s*\d)?(?(1)(.{1,5})(?=(\s{1,}))(?<!(\s{2}))(.{1,5}) thanks|\s*thanks)$", flags=re.MULTILINE)
test_str = ("Dear user 1 2222 thanks\n"
"Dear user12345 64789 thanks\n"
"Dear user12345 6479 thanks\n"
"Dear user12345 6489 thanks\n"
"Dear user 12345 64789 thanks\n"
"Dear user 123 5 6789 thanks\n"
"Dear user 123 5 68 4 thanks\n"
"Dear user 1 thanks\n"
"Dear user thanks\n"
"Dear user 1 2 thanks\n"
"Dear user 43265 thanks\n"
"Dear user 43265 thanks\n"
"Dear user thanks\n"
"Dear user thanks")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")