#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\[\[([^|]+)\|([^\]]+)\]\]"
Local $sString = "Text [[Link A|http:\/\/ab.x.yz]] text. Text [[Link B|http:\/\/cd.u.vw]] text." & @CRLF & _
"Text [[Link C|http:\/\/ef.r.st]] text." & @CRLF & _
"Text [[Link D|http:\/\/hi.o.pq]] text. Text [[Link E|http:\/\/ik.l.mn]] text." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")