const regex = /\[\[([^|]+)\|([^\]]+)\]\]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[\\[([^|]+)\\|([^\\]]+)\\]\\]', 'g')
const str = `Text [[Link A|http:\\/\\/ab.x.yz]] text. Text [[Link B|http:\\/\\/cd.u.vw]] text.
Text [[Link C|http:\\/\\/ef.r.st]] text.
Text [[Link D|http:\\/\\/hi.o.pq]] text. Text [[Link E|http:\\/\\/ik.l.mn]] text.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}