package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[\[([^|]+)\|([^\]]+)\]\]`)
var str = `Text [[Link A|http:\/\/ab.x.yz]] text. Text [[Link B|http:\/\/cd.u.vw]] text.
Text [[Link C|http:\/\/ef.r.st]] text.
Text [[Link D|http:\/\/hi.o.pq]] text. Text [[Link E|http:\/\/ik.l.mn]] text.
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}