re = /\[\[([^|]+)\|([^\]]+)\]\]/
str = 'Text [[Link A|http:\\/\\/ab.x.yz]] text. Text [[Link B|http:\\/\\/cd.u.vw]] text.
Text [[Link C|http:\\/\\/ef.r.st]] text.
Text [[Link D|http:\\/\\/hi.o.pq]] text. Text [[Link E|http:\\/\\/ik.l.mn]] text.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end