// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[\[([^|]+)\|([^\]]+)\]\]").unwrap();
let string = "Text [[Link A|http:\\/\\/ab.x.yz]] text. Text [[Link B|http:\\/\\/cd.u.vw]] text.
Text [[Link C|http:\\/\\/ef.r.st]] text.
Text [[Link D|http:\\/\\/hi.o.pq]] text. Text [[Link E|http:\\/\\/ik.l.mn]] text.
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}