$re = '/\[\[([^|]+)\|([^\]]+)\]\]/';
$str = 'Text [[Link A|http:\\/\\/ab.x.yz]] text. Text [[Link B|http:\\/\\/cd.u.vw]] text.
Text [[Link C|http:\\/\\/ef.r.st]] text.
Text [[Link D|http:\\/\\/hi.o.pq]] text. Text [[Link E|http:\\/\\/ik.l.mn]] text.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);