package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)*`)
var str = `from:arthurlurry<admin@yyy.com>reply-to:admin@yyy.comto:RonaldoDemelop<xxxGmail.com>ytut7t6ioy9mu795-date:Mar30,2022,8:28PMsubject:HowSchoolBoysUsedToWriteLettersToGirlsInThe80sAnd90s..Romance..2vakj0t1..security:Standardencryption(TLS)Learnmore`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}