re = /*/m
str = 'from:arthurlurry<admin@yyy.com>reply-to:admin@yyy.comto:RonaldoDemelop<xxxGmail.com>ytut7t6ioy9mu795-date:Mar30,2022,8:28PMsubject:HowSchoolBoysUsedToWriteLettersToGirlsInThe80sAnd90s..Romance..2vakj0t1..security:Standardencryption(TLS)Learnmore'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end