// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)*").unwrap();
let string = "from:arthurlurry<admin@yyy.com>reply-to:admin@yyy.comto:RonaldoDemelop<xxxGmail.com>ytut7t6ioy9mu795-date:Mar30,2022,8:28PMsubject:HowSchoolBoysUsedToWriteLettersToGirlsInThe80sAnd90s..Romance..2vakj0t1..security:Standardencryption(TLS)Learnmore";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}