import re
regex = re.compile(r"*", flags=re.MULTILINE)
test_str = "from:arthurlurry<admin@yyy.com>reply-to:admin@yyy.comto:RonaldoDemelop<xxxGmail.com>ytut7t6ioy9mu795-date:Mar30,2022,8:28PMsubject:HowSchoolBoysUsedToWriteLettersToGirlsInThe80sAnd90s..Romance..2vakj0t1..security:Standardencryption(TLS)Learnmore"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")