# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?:https?:\/\/)?((?:[\p{L}\p{N}-]+\.)+[\p{L}\p{N}-]+)\b/<a href="http:\/\/$1" target="_blank">test.com<\/a>/gm;t' <<< "www.test.com
https://test.com
https://www.test.com
<a href=\"https://test.com\" target=\"_blank\">test.com</a>"