use strict;
my $str = 'www.test.com
https://test.com
https://www.test.com
<a href="https://test.com" target="_blank">test.com</a>';
my $regex = qr~^(?:https?://)?((?:[\p{L}\p{N}-]+\.)+[\p{L}\p{N}-]+)\b~mp;
my $subst = '<a href="http://$1" target="_blank">test.com</a>';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";