import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:https?://)?((?:[\\p{L}\\p{N}-]+\\.)+[\\p{L}\\p{N}-]+)\\b";
final String string = "www.test.com\n"
+ "https://test.com\n"
+ "https://www.test.com\n"
+ "<a href=\"https://test.com\" target=\"_blank\">test.com</a>";
final String subst = "<a href=\"http://$1\" target=\"_blank\">test.com</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}