using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:https?://)?((?:[\p{L}\p{N}-]+\.)+[\p{L}\p{N}-]+)\b";
string substitution = @"<a href=""http://$1"" target=""_blank"">test.com</a>";
string input = @"www.test.com
https://test.com
https://www.test.com
<a href=""https://test.com"" target=""_blank"">test.com</a>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}