$re = '~^(?:https?://)?((?:[\p{L}\p{N}-]+\.)+[\p{L}\p{N}-]+)\b~m';
$str = 'www.test.com
https://test.com
https://www.test.com
<a href="https://test.com" target="_blank">test.com</a>';
$subst = "<a href=\"http://$1\" target=\"_blank\">test.com</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;