// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:https?://)?((?:[\p{L}\p{N}-]+\.)+[\p{L}\p{N}-]+)\b").unwrap();
let string = "www.test.com
https://test.com
https://www.test.com
<a href=\"https://test.com\" target=\"_blank\">test.com</a>";
let substitution = "<a href=\"http://$1\" target=\"_blank\">test.com</a>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}